Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001581Dwarf FortressDwarf Mode -- Jobs, Burialpublic2010-04-27 10:212012-02-10 07:36
Reporterultimate carl 
Assigned ToDwarfu 
PrioritylowSeverityminorReproducibilityhave not tried
StatusresolvedResolutionunable to reproduce 
PlatformPCOSWindows VistaOS VersionProfessional SP2
Product Version0.31.03 
Target VersionFixed in Version 
Summary0001581: "Misplaced" dwarf corpse ignored instead of buried.
DescriptionI had a dwarf die from starvation due to insanity, and built a new coffin and placed it for him to be put in. I wasn't really watching this, but got a "canceled: misplaced object" message for the corpse.

Removing and replacing all empty coffins (and even my outside graveyard stockpile) did not get them to try again. Designating the body for dumping did nothing. The body is just sitting there in the middle of my food stockpile and is completely ignored no matter what I try.

I wasn't watching when he died, so I am unsure if he died in the food stockpile or if he was dropped there by whoever was hauling him, but that may have something to do with it.
Steps To Reproduce1) Kill a dwarf.
2) Build a coffin and designate it for burial.
3) Let Urist McScrewUp do it wrong.
4) Make all of your dwarves cry as they see a rotting corpse every time they want a drink.
Additional InformationI powered through it and continued playing, but later lost that fortress so unfortunately I do not have a save of this. I haven't had it happen in another fortress since, either.
Tagscorpse, death
Attached Files

- Relationships

-  Notes
Logical2u (manager)
2010-04-27 10:27

... since you don't have a save, and don't know the reproducibility, I'm not sure if you can answer these questions, but they may be helpful in attempting to reproduce the issue.

1. Did it persist after save/load?
2. Were you using Burrows?

Probably related to 0000790.
ultimate carl (reporter)
2010-04-27 10:39


1) I'm not 100%, but I'm pretty sure I saved, closed the game, and continued playing the next day with the same problem.
2) Nope.
Logical2u (manager)
2010-04-27 10:42

Was he outside or inside when he died, and did you have any unusual standing orders set up?
ultimate carl (reporter)
2010-04-27 10:44

Inside (if I remember properly he went crazy and just moped in a corner until starving), and no, all the normal orders were set.
Footkerchief (manager)
2010-04-27 12:54

Is there any possibility you could have forbidden the corpse by accident?
Dwarfu (manager)
2010-08-27 02:09

Reminder sent to: ultimate carl

Are you able to provide any further information on this bug, or have you been able to reproduce it in a current version (31.12 or above)?
Dwarfu (manager)
2010-12-09 11:26

If this can be reproduced in a current version, please reopen this report.
Footkerchief (manager)
2012-02-08 06:46
edited on: 2012-02-08 06:47

Reminder sent to: JasonMel

Reopening as per [^]

And yeah, a PM to the managers (me, Dwarfu, Logical2u, Knight Otu) works well in these circumstances.

JasonMel (reporter)
2012-02-08 09:15

Vanilla DF PC 31.25 SDL on WinXP Pro SP3
using Dwarf Therapist, Stonesense Slate, and (very occasionally, and not running at the time) Ogreseer

Alright, so I intentionally collapsed scaffolding just outside the entrance to the underground portion of the fort. The collapse "crushed" a dwarven child outright, killing him, and three others died from injuries ("suffocated") before they could be taken to the hospital underground. The three who "suffocated" were carried to the corpse stockpile more or less immediately, and subsequently interred in sarcophagi newly placed for them, all underground. Three game days later, the fourth sarcophagus, also marked for burial, was never filled. I kept strict track of the jobs that were generated following the accident, and no dwarf ever moved to pick up the crushing victim, either to bring it to the corpse stockpile or to bury him in his own coffin, which says "This is the resting place of <the victim>." in its <q>uery screen.

I don't think it was an issue of labor shortage, since anywhere from 20 to 60 dwarves have been idle the whole time, most or all with full hauling labors active.

I also don't think it was an issue of where the corpse came to rest, since one of the suffocation victims came to rest, dead, right beside the crushing victim. Both tiles were "inside, light, above ground," and both were in 3/7 water (it was a dwarven bathtub; the scaffolding was for the construction of a 4-pump mist generator above it).

I have corpses set to be forbidden on death, to prevent corpse haulers from wandering into dangerous situations, but I unforbade the corpse immediately to get him buried in a timely way, same as all the others.

Only three game days have passed since the accident, and all the relevant announcements are still in the buffer. I can provide a savegame, and I can probably even provide a detailed in-game schematic of the events using notes and/or burrows, if someone will assist me in creating a backup of my save and uploading it somewhere.
Footkerchief (manager)
2012-02-08 10:23

The savegame would be appreciated, yeah. [^]
JasonMel (reporter)
2012-02-08 10:47

Sure. How do I create a backed-up savegame for upload?
i2amroy (reporter)
2012-02-08 10:58

Just go into your data/save/ folder and find the folder that has the same title as your game region. Then just copy and paste that somewhere else, zip it up, and then upload it.
JasonMel (reporter)
2012-02-08 14:35
edited on: 2012-02-08 14:37

The savegame ( [^]) is uploaded, with notes added to illustrate the events as best I can recall. The collapse was in the northeast quadrant of the area enclosed by the fort's large outer wall on level Z=0; the corpse stockpile and sarcophagi are all on the southern end of level Z=-6.

A total of 8 notes and 3 burrows added as illustrations, all named with the prefix "NB:". If anything's unclear, I'd be happy to clarify it if I can.

Additional facts: There was also a named pet blue peahen who suffocated from injuries but whom I had no interest in burying, three injured dwarves recovering in the hospital, and four or five more injured animals, all resulting from the collapse.

I also had a 4-by-5 stone stockpile in the collapse area, which may account for all the cancelled job notices in the buffer following the collapse. The stockpile is now gone, and I don't remember ever undesignating it.

After saving and submitting this save, I let the game progress for another 2 months, and still nothing was done with the offending corspe. I did notice that no creatures seem ever to enter the square the corpse occupies, either, and I can't understand why that is.

It's probably not related, but I had a problem with corpses I could never find in the previous game year. After a migrant wave was decimated by a titan who arrived nearly simultaneously, it was hard to keep track of all the death. Their ghosts haunted the fort until I built memorials to the missing dwarves.

Victims, in order of death:
Tekkud Kelzuglar (M, age 1): Crushed. Died the same tick as the collapse occurred. Came to rest in the water bath just outside the entrance. Has not been moved.
Atir Inenurist (M, age 2): Suffocated. Died after the collapse but before rescuers could arrive. Tekkud's brother. Came to rest next to Tekkud in the bath. Currently buried.
Datan Mezmebzuth (F, age 61): Suffocated. Died after the collapse but before rescuers could arrive. Currently buried.
Urdim Uruslitast, Blue Peahen: Suffocated. Died after the collapse.
Monom Kibmishos (M, age 1): Suffocated while being carried to the hospital. Currently buried.

[Just as an aside, the FB who appeared shortly after the accident is the first one I've ever seen, so that's exciting.]

Dwarfu (manager)
2012-02-08 21:54

Because he is in the water, I believe your issue is more of an instance of 0000895. The dwarves won't dump any of the stone (shale) on that tile, either.

I managed to get them to get the corpse by deconstructing just the lower (south) block ramp. Water then pushed to corpse to the upper (north) ramp (or revealed its true location) and someone came along and carted the corpse off to the coffin.
JasonMel (reporter)
2012-02-08 22:45

Wow, thanks! Sorry, didn't know about that other bug.
Dwarfu (manager)
2012-02-10 07:36

Thanks for the follow-ups and being thorough in your reporting (being descriptive and using in-game notes, etc.), it certainly helps.

I've moved your save and linked the related notes in 0000895. There certainly seems to be some rampy-watery-flaggy thing going on, but since the OP here didn't provide a save, there wasnt' much we could do with it. I didn't see the same message in your save as the OP had, either, so I'm closing this report out again so yours can get looked at with 0000895.

- Issue History
Date Modified Username Field Change
2010-04-27 10:21 ultimate carl New Issue
2010-04-27 10:27 Logical2u Note Added: 0005354
2010-04-27 10:39 ultimate carl Note Added: 0005356
2010-04-27 10:42 Logical2u Note Added: 0005357
2010-04-27 10:44 ultimate carl Note Added: 0005358
2010-04-27 10:45 ultimate carl Tag Attached: death
2010-04-27 10:45 ultimate carl Tag Attached: corpse
2010-04-27 12:54 Footkerchief Note Added: 0005376
2010-04-27 12:54 Footkerchief Issue Monitored: Footkerchief
2010-08-27 02:09 Dwarfu Note Added: 0012135
2010-08-27 02:10 Dwarfu Tag Attached: AWAITING UPDATE
2010-12-09 11:26 Dwarfu Tag Detached: AWAITING UPDATE
2010-12-09 11:26 Dwarfu Note Added: 0014472
2010-12-09 11:26 Dwarfu Status new => resolved
2010-12-09 11:26 Dwarfu Resolution open => unable to reproduce
2010-12-09 11:26 Dwarfu Assigned To => Dwarfu
2012-02-08 06:46 Footkerchief Assigned To Dwarfu =>
2012-02-08 06:46 Footkerchief Status resolved => new
2012-02-08 06:46 Footkerchief Issue Monitored: JasonMel
2012-02-08 06:46 Footkerchief Note Added: 0019461
2012-02-08 06:47 Footkerchief Note Edited: 0019461 View Revisions
2012-02-08 06:47 Footkerchief Note Edited: 0019461 View Revisions
2012-02-08 09:15 JasonMel Note Added: 0019462
2012-02-08 10:23 Footkerchief Note Added: 0019463
2012-02-08 10:47 JasonMel Note Added: 0019464
2012-02-08 10:58 i2amroy Note Added: 0019465
2012-02-08 14:35 JasonMel Note Added: 0019466
2012-02-08 14:36 JasonMel Note Edited: 0019466 View Revisions
2012-02-08 14:37 JasonMel Note Edited: 0019466 View Revisions
2012-02-08 21:54 Dwarfu Note Added: 0019468
2012-02-08 22:45 JasonMel Note Added: 0019470
2012-02-10 07:36 Dwarfu Note Added: 0019475
2012-02-10 07:36 Dwarfu Status new => resolved
2012-02-10 07:36 Dwarfu Assigned To => Dwarfu

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker