Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003869Dwarf FortressPathfindingpublic2011-01-05 03:572017-01-27 13:08
ReporterKipi 
Assigned ToFootkerchief 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusassignedResolutionreopened 
PlatformOSWindowsOS Version7
Product Version0.31.18 
Target VersionFixed in Version0.40.10 
Summary0003869: Drop in FPS when moody dwarf can't path to workshop
DescriptionI had a group of immigrants arriving, but they decide to appear to the map in location which has no access to the fortress due stream running between them and the entrance. One immigrant got moody soon after that, and I ordered the correct workshop to be built while waiting the bridge to get ready for migrants to get over the stream. At this point everything was normal, FPS was somewhere between 250 and 300, it's still young fortress after all.

Now, immediately after the workshop was ready the FPS dropped to between 30 and 40. The FPS stayed at those numbers to the point when the bridge was finally ready, and then it got straight back to the 300.

So, my conclusion is, if you have moody dwarf, and there is correct workshop but the dwarf can not reach it due block or something (in my case stream), the pathfinding goes wonky and the FPS gets major hit.
Steps To ReproduceHaven't tested this out yet but the steps could be the following:

1) Get moody dwarf
2) Block the path to the correct workshop with something (don't know if it must be land feature or if anything goes)
3) See the sudden drop of FPS
TagsNo tags attached.
Attached Files

- Relationships
related to 0002945new Animal trainer selects animal behind pet-impassable door, waits forever for animal to arrive at kennel 
has duplicate 0004153resolvedFootkerchief Trapped Moody Dwarf slows game 
has duplicate 0008002resolvedFootkerchief After Vampire Fey mood, simulation speed drops like a stone, 
has duplicate 0010573resolvedLoci Moody dwarf tries to path through closed bridge 
related to 0007284resolvedToady One Lag when dwarves stuck in a tree get a strange mood 
related to 0010123new Active soldier locked in a room will try to go to practice, fail to find a path, and kill FPS 
related to 0008698confirmedFootkerchief Dwarf entering a strange mood when isolated (e.g. on a stepladder) causes severe lag 

-  Notes
(0014791)
Logical2u (manager)
2011-01-05 05:25

Another example of pathfinding updates causing lag when items are inaccessible. Ostensibly also related to the better known 0001340 but 0002945 seems more relevant in this situation.
(0014801)
Footkerchief (manager)
2011-01-06 08:07

Reminder sent to: Kipi

If you have a save demonstrating this problem, please upload it to http://dffd.wimbli.com/ [^]

What kind of mood does the dwarf have?
(0019104)
Logical2u (manager)
2011-12-10 09:29

Without further updates I'm resolving this report. Also the relations to this report could also cover it.
(0029054)
thraxarious (reporter)
2014-08-14 14:34

I have an referenced save to upload from 0008002, but for some reason dffd is being persnickety and won't let me upload. keeps giving me server erors no matter which browser.
(0029067)
thraxarious (reporter)
2014-08-14 18:29

http://dffd.wimbli.com/file.php?id=9395 [^]

Relevant save file, log file fills with pathing errors, just fills.

path fail: dwarf,Strange Mood,136,96,109 -> 69,117,109: Id 0005291:Path Goal Set Mood Building:Station Milling

Vampire can't path out to a workshop so the game is constantly trying to find him a path. The constant runaway pathing lags the simulator down to a crawl.

It might make keeping vampires as bookkeepers or some other noble tricky, having a strange mood hit them. Worse yet becoming "insane" from failing it and not being able to die of thirst.

When released to craft, I dug down deep enough to get the needed components, he finished making the item and right away went to drain a dwarf before I could put him back.
(0032632)
Footkerchief (manager)
2015-05-01 12:46

Reopened awaiting a save from Dwachs.
(0032633)
Dwachs (reporter)
2015-05-02 05:53

Here is the savegame:

http://dffd.bay12games.com/file.php?id=10816 [^]

It is centered on the moody dwarf. She is walled-in due to were-infection, and thus cannot reach any craftdwarf's workshop. There are 3 present, but not reachable for her. FPS drops to 6. The FPS drop is also present while in were-form.

(In my game I waited until she transformed and went back to dwarf form, then opened a way to a workshop, where she eventually completed an artifact.)

- Issue History
Date Modified Username Field Change
2011-01-05 03:57 Kipi New Issue
2011-01-05 05:24 Logical2u Relationship added related to 0002945
2011-01-05 05:25 Logical2u Note Added: 0014791
2011-01-06 08:07 Footkerchief Note Added: 0014800
2011-01-06 08:07 Footkerchief Note Edited: 0014800 View Revisions
2011-01-06 08:07 Footkerchief Note Deleted: 0014800
2011-01-06 08:07 Footkerchief Note Added: 0014801
2011-01-06 08:07 Footkerchief Tag Attached: AWAITING UPDATE
2011-12-10 09:29 Logical2u Note Added: 0019104
2011-12-10 09:29 Logical2u Status new => resolved
2011-12-10 09:29 Logical2u Resolution open => unable to reproduce
2011-12-10 09:29 Logical2u Assigned To => Logical2u
2011-12-10 09:29 Logical2u Tag Detached: AWAITING UPDATE
2014-08-14 10:29 Footkerchief Summary Moody dwarf causes major drop in FPS => Drop in FPS when moody dwarf can't path to workshop
2014-08-14 10:29 Footkerchief Assigned To Logical2u => Footkerchief
2014-08-14 10:29 Footkerchief Status resolved => confirmed
2014-08-14 10:30 Footkerchief Relationship added has duplicate 0004153
2014-08-14 10:30 Footkerchief Relationship added has duplicate 0008002
2014-08-14 10:31 Footkerchief Relationship added related to 0007284
2014-08-14 14:34 thraxarious Note Added: 0029054
2014-08-14 18:29 thraxarious Note Added: 0029067
2014-08-14 18:35 Footkerchief Resolution unable to reproduce => open
2014-08-20 13:58 Toady One Status confirmed => resolved
2014-08-20 13:58 Toady One Fixed in Version => Next Version
2014-08-20 13:58 Toady One Resolution open => fixed
2014-08-20 13:58 Toady One Assigned To Footkerchief => Toady One
2015-05-01 12:46 Footkerchief Assigned To Toady One => Footkerchief
2015-05-01 12:46 Footkerchief Note Added: 0032632
2015-05-01 12:46 Footkerchief Status resolved => needs feedback
2015-05-01 12:46 Footkerchief Resolution fixed => reopened
2015-05-02 05:53 Dwachs Note Added: 0032633
2015-05-02 05:53 Dwachs Issue Monitored: Dwachs
2017-01-27 13:07 Loci Relationship added related to 0010123
2017-01-27 13:08 Loci Status needs feedback => assigned
2018-02-12 13:37 Loci Relationship added has duplicate 0010573
2018-02-12 13:39 Loci Relationship added related to 0008698


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker