Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005021Dwarf FortressDwarf Mode -- Tradepublic2012-01-12 20:472016-05-06 16:24
ReporterGreymane 
Assigned ToToady One 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version0.31.25 
Target VersionFixed in Version0.43.01 
Summary0005021: "Masterwork has been lost" when merchants leave with traded items
DescriptionAs soon as visiting merchants leave the map, masterwork items traded to merchants are reported as stolen ('A masterwork of [dwarf] has been lost!') with accompanying negative thoughts for the creator. Have so far tested it on crafts of all kinds (mugs included), nest boxes, weapons, ammo, bins, and barrels.
Steps To ReproduceTrade a masterwork quality item to any merchant and wait for them to leave the map with the item.
Additional InformationSaves:
http://dffd.bay12games.com/file.php?id=11784 [^] (0.42.06)
http://dffd.bay12games.com/file.php?id=11787 [^] (0.42.06)
http://dffd.bay12games.com/file.php?id=11859 [^] (0.42.06)
Tags0.42.06
Attached Files

- Relationships
has duplicate 0009576resolvedlethosor Sold master quality items reported as "lost masterworks" upon merchants leaving the map 
has duplicate 0009691resolvedKnight Otu Masterworks lost through trade 
related to 0003169needs feedbackFootkerchief Bone carvers suffer art defacement when somebody leaves the map with stuck-in masterpiece bolts 
related to 0005441new Modded Civ with Flee/Hide Interaction triggers Ambush pause with diplomat 
related to 0005442new Traders leaving map with their own caged Animal triggers snatcher pause 
related to 0009780resolvedToady One Traded masterwork meals result in "Masterwork has been lost" message 

-  Notes
(0019372)
Kogut (reporter)
2012-01-13 05:06

Please, upload savegame (it never happened in my game)
(0019374)
Quietust (reporter)
2012-01-13 06:02

By any chance are you trading with a (modded) Kobold civilization?
(0019378)
Dwarfu (manager)
2012-01-13 09:14

Reminder sent to: Greymane

Can you update this report with a save (zip you DF/data/save/region folder and upload it to http://dffd.wimbli.com [^] and post a link in the bug report) and let us know if you are using any mods (such as a modded kobold civ, etc).
(0019386)
Greymane (reporter)
2012-01-13 14:31
edited on: 2012-01-13 15:57

http://dffd.wimbli.com/file.php?id=5360 [^]

Save is up. I AM using mods, nameless homebrew stuff that does include a couple alterations to the Kobold civilization.

Oddly, while I had seen this happen in completely clean, unmodded worlds before I started modding, I actually can't seem to get it to repeat in a clean game anymore. Might have jumped the gun on a bug report, if it's the fault of the mods.

EDIT: Just to specifically address the question Quietust asked (which I had misread at first), the trading in question is not with Kobolds, who are not modded for trade (just a few equipment and job related things). Trade is still only with dwarves, elves, and humans and the bug crops up with all of them.

(0019396)
Kogut (reporter)
2012-01-16 04:25

Are you playing as kobold civ?
(0019398)
Greymane (reporter)
2012-01-16 15:44

Kogut: Belatedly, nope. Just dwarves. In most of the worlds/forts it happened in, there weren't even any kobolds because they'd all died out. Whatever was causing it wasn't kobold-related.
(0031611)
ptb_ptb (reporter)
2014-12-31 05:05

I haven't seen this in DF 0.40.~~ Maybe it can be closed?
(0031615)
Footkerchief (manager)
2014-12-31 07:54

Anyone able to reproduce this with or without mods?
(0031626)
vomov (reporter)
2015-01-01 01:57

I can't seem to reproduce this, because I can't trade masterwork stuff (not even through messing around with bins), which I think is intended behaviour (maybe for now, but still intended). I've not seen this issue for quite some time, so I suspect it can be closed.
(0031628)
ptb_ptb (reporter)
2015-01-01 02:44

@vomov Not being able to trade Artifacts is as intended. Not being able to trade Masterwork (would be) a bug.
(0031640)
Detros (manager)
2015-01-02 10:45

No, Footkerchief. I am selling masterful ☼trap component☼s to dwarves and humans in 40.23 and neither such message nor bad thoughts of my carpenters noted.
(0031698)
vomov (reporter)
2015-01-05 03:43

@ptb_ptb: mixed the terms 'Masterwork' and 'Artefact', whoops! (the negative thought threw me off)

Selling or getting rid of Masterwork stuff isn't a problem, as far as I can see; I've been deforesting aggressively and selling masterwork stuff for quite some time now, without issues.

Artefacts being non-tradable and the bad thoughts etc. resulting from a loss seems to be working as intended.
(0031700)
Detros (manager)
2015-01-05 09:02

So, can this be closed as "no more in current version"/"maybe caused by a mod" or something like that, at least until somebody manages to reproduce it in 0.40.20 or higher version?
(0031720)
Footkerchief (manager)
2015-01-05 17:00

That seems reasonable.

If anyone has a save that reproduces this problem in the latest version, please upload it to http://dffd.wimbli.com/ [^] and PM a manager on the forums (or reopen the report).
(0034860)
lethosor (manager)
2016-03-16 14:29

Reopened per 0009576 and http://www.bay12forums.com/smf/index.php?topic=52185.msg6876977#msg6876977 [^]

Save from VitalArt on the forums: http://dffd.bay12games.com/file.php?id=11859 [^]

Saves from 0009576:
http://dffd.bay12games.com/file.php?id=11784 [^]
http://dffd.bay12games.com/file.php?id=11787 [^]
(0034872)
SpoCk0nd0pe (reporter)
2016-03-18 14:05

I just wanted to report it happened in my fort too. Do you still need another save?
(0034874)
seeschloss (reporter)
2016-03-19 08:40

Just in case it can be useful, here's a save where this happened to me:

http://dffd.bay12games.com/file.php?id=11871 [^]

On a completely unmoded game.
(0034965)
DaliTimelord (reporter)
2016-04-02 17:28

Also happened to me after the merchants left the map.

http://dffd.bay12games.com/file.php?id=11911 [^]

Unmodded, now with fancy screenshots!
(0034984)
Aussiemon (reporter)
2016-04-07 23:52

In case it might assist further, here is another save, taken just before the traders leave the map with the "lost" masterwork.

http://dffd.bay12games.com/file.php?id=11922 [^]

- Issue History
Date Modified Username Field Change
2012-01-12 20:47 Greymane New Issue
2012-01-12 22:22 Footkerchief Relationship added related to 0003169
2012-01-13 05:06 Kogut Note Added: 0019372
2012-01-13 06:02 Quietust Note Added: 0019374
2012-01-13 07:01 Footkerchief Tag Attached: AWAITING UPDATE
2012-01-13 09:14 Dwarfu Note Added: 0019378
2012-01-13 14:31 Greymane Note Added: 0019386
2012-01-13 14:42 Greymane Tag Attached: UPDATE GIVEN
2012-01-13 15:57 Greymane Note Edited: 0019386 View Revisions
2012-01-13 16:27 Footkerchief Tag Detached: AWAITING UPDATE
2012-01-13 16:27 Footkerchief Tag Detached: UPDATE GIVEN
2012-01-13 16:27 Footkerchief Summary Traded Masterworks Count As Stolen => "Masterwork has been lost" when merchants leave with traded items
2012-01-16 04:25 Kogut Note Added: 0019396
2012-01-16 15:44 Greymane Note Added: 0019398
2012-02-25 12:45 Footkerchief Relationship added related to 0005441
2012-02-25 12:46 Footkerchief Relationship added related to 0005442
2014-12-31 05:05 ptb_ptb Note Added: 0031611
2014-12-31 07:54 Footkerchief Note Added: 0031615
2014-12-31 07:54 Footkerchief Assigned To => Footkerchief
2014-12-31 07:54 Footkerchief Status new => needs feedback
2015-01-01 01:57 vomov Note Added: 0031626
2015-01-01 02:44 ptb_ptb Note Added: 0031628
2015-01-02 10:45 Detros Note Added: 0031640
2015-01-02 10:45 Detros Issue Monitored: Detros
2015-01-05 03:43 vomov Note Added: 0031698
2015-01-05 03:43 vomov Issue Monitored: vomov
2015-01-05 09:02 Detros Note Added: 0031700
2015-01-05 17:00 Footkerchief Note Added: 0031720
2015-01-05 17:00 Footkerchief Status needs feedback => resolved
2015-01-05 17:00 Footkerchief Resolution open => unable to reproduce
2016-03-16 14:16 VitalArt Issue Monitored: VitalArt
2016-03-16 14:16 VitalArt Issue End Monitor: VitalArt
2016-03-16 14:28 lethosor Relationship added has duplicate 0009576
2016-03-16 14:28 lethosor Issue Monitored: Button
2016-03-16 14:28 lethosor Issue Monitored: Sarmatian123
2016-03-16 14:28 lethosor Issue Monitored: madman256
2016-03-16 14:29 lethosor Note Added: 0034860
2016-03-16 14:29 lethosor Status resolved => needs feedback
2016-03-16 14:29 lethosor Resolution unable to reproduce => reopened
2016-03-16 14:31 lethosor Additional Information Updated View Revisions
2016-03-18 14:05 SpoCk0nd0pe Note Added: 0034872
2016-03-18 19:20 Sarmatian123 Tag Attached: 0.42.06
2016-03-19 08:40 seeschloss Note Added: 0034874
2016-04-02 17:28 DaliTimelord Note Added: 0034965
2016-04-07 23:52 Aussiemon Note Added: 0034984
2016-04-15 02:16 Knight Otu Status needs feedback => confirmed
2016-04-15 02:17 Knight Otu Relationship added has duplicate 0009691
2016-05-06 16:24 Toady One Status confirmed => resolved
2016-05-06 16:24 Toady One Fixed in Version => Next Version
2016-05-06 16:24 Toady One Resolution reopened => fixed
2016-05-06 16:24 Toady One Assigned To Footkerchief => Toady One
2016-05-09 23:47 Button Issue End Monitor: Button
2016-05-29 19:36 Dwarfu Relationship added related to 0009780
2016-12-22 07:30 AxDeath Issue Monitored: AxDeath


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker