Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006737Dwarf FortressDwarf Mode -- Environmentpublic2014-07-08 16:342015-12-18 19:56
Reporterpsioryx 
Assigned ToToady One 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusconfirmedResolutionreopened 
PlatformMacOSOSXOS Version10.9.4
Product Version0.40.01 
Target VersionFixed in Version0.40.10 
Summary0006737: Flying animals (e.g. birds) stuck in mid air (prevents invasions?)
DescriptionHave had 3 ravens several z levels up, no trees around, just sitting there in the same spot for several seasons now.
Steps To Reproduceno idea
Additional InformationLots of other stuff flying around as they should.
TagsNo tags attached.
Attached Files

- Relationships
related to 0007651resolvedToady One Default ORIENTATION excludes some animals from breeding 
has duplicate 0007028resolvedFootkerchief Keas will steal items and not leave the embark site. 
has duplicate 0007093resolvedFootkerchief Flying creatures stuck in the skies, possibly causing massive FPS drops due to broken pathfinding 
has duplicate 0007644resolvedFootkerchief Flying animals trapped 
has duplicate 0007742resolvedFootkerchief [FLIER] Tag causes several issues, including ceased movement of creatures and zero invaders as well as FPS issues. 
has duplicate 0007926resolvedDwarfu The wild Animals stay always 
has duplicate 0007973resolvedFootkerchief Birds get stuck mid-air 
has duplicate 0007840resolvedFootkerchief Undead creatures are sticked to the borders of the map 
related to 0007170resolvedToady One Troglodytes get stuck while climbing 
related to 0005421new Adventurer flight empairment 
related to 0006545resolvedToady One Flying creatures stop flying, fall to the ground, and explode 
related to 0009362confirmedLoci Flying visitors hovering near map edge and not pathing to tavern 

-  Notes
(0025178)
Footkerchief (manager)
2014-07-08 16:49

Please upload a save that demonstrates the problem to http://dffd.wimbli.com/ [^] and post the link here.
(0025200)
psioryx (reporter)
2014-07-08 18:30

The issue went away eventually. I can still provide the save file if it will help. It currently has another issue in progress: Necromancer of siege is not leaving edge of map.
(0025919)
Footkerchief (manager)
2014-07-11 20:21

Orkel posted a save at 0007093: http://dffd.wimbli.com/file.php?id=8887 [^]
(0025963)
4maskwolf (reporter)
2014-07-12 05:53

If we're talking about immobile creatures, a similar thing with creatures not moving is happening in a current fort with undead on the edge of the map.
(0026023)
eliotcougar (reporter)
2014-07-12 14:21

I'm not sure I should open an additional issue while there're so many flying relater issues that may have common cause...
Does anyone notice that in adventure mode almost all birds just sit on the ground and don't even try to fly away if you attack them?..
(0026027)
Rafal99 (reporter)
2014-07-12 14:55

In my fort I had a cluster of 9 Raven Men/Women sitting in midair about 10 z-levels above ground for 4 ingame months. During that time no other above-ground animals spawned on my map.
Eventually I got a quiver from dead goblins so I could send a marksdwarf to shoot them down. Once some of them got hit they all dispersed in horror and flew in all directions.
(0026312)
frodo0800 (reporter)
2014-07-14 06:38

The issue seems to be present on .03 too. And the same thing happened to me Rafal99, except I removed the flier tag from them so they could stop lagging everything.
(0026947)
exottoyuhr (reporter)
2014-07-19 08:21
edited on: 2014-07-19 08:42

I think this happens -- sporadically -- with all flying creatures. In Losing Is !!Magic!! for 40.03, I saw a pegasus get stuck in the air next to a constructed wall, blinking some sort of brown color. (I told him to dismantle the wall, then cancelled that order, and his pathing went back to normal and he got back to work.)

(0027093)
lethosor (manager)
2014-07-20 19:40

Reminder sent to: eliotcougar, frodo0800, psioryx, Rafal99

As mentioned in 0005421:0026952, this could be the same problem as 0006737. Can you check the tiles surrounding the stuck creatures with [k] to see if they are listed as "open space" or simply blank? (Preferably in the current version of DF, since 0.40.01-02 saves aren't compatible with the latest DF version.)
(0027585)
Rafal99 (reporter)
2014-07-26 05:14
edited on: 2014-07-26 05:14

Unfortunately I don't have any forts in 40.03+ atm, but I loaded my save with this bug in DF 40.02 and checked the tiles where the Raven Men are stuck and all of these tiles and all the surrouding tiles too show as "Open space".

But reading 0005421 it seems that open space refers there to any air tiles that are loaded, rather than to tiles being listed as "Open space" in the look menu.

(0027606)
Kirkegaard (reporter)
2014-07-26 08:09
edited on: 2014-07-26 08:10

@lethosor
I have a fort with 9 keas stuck in the air around the map. They are all in "open space". There is also 2 Hedgehog womans that have crawled up in a tree and are stuck now, they are not marked as in "open space"
Should I upload a save?
(version 0.40.3)

(0027607)
Dwarfu (manager)
2014-07-26 08:16

Reminder sent to: Kirkegaard

Yes, upload the save and post a link in the report.
(0027608)
Kirkegaard (reporter)
2014-07-26 08:34

Save: http://dffd.wimbli.com/file.php?id=9160 [^]
(0027845)
Talvieno (reporter)
2014-07-28 20:13

I have three stuck keas as well.
(0027985)
Ataman (reporter)
2014-07-30 15:33
edited on: 2014-08-05 03:36

This bug really needs fixing birds being stuck blocks sieges and any form of hostiles as well.

In short:
Stuck birds = No Invaders, No Megabeasts, No Wildlife and No Forgotten Beasts.

EDIT: (I might be wrong about beasts though).
Save for vanilla 40.06: http://dffd.wimbli.com/file.php?id=9292 [^]

(0028655)
tacomagic (reporter)
2014-08-09 11:30
edited on: 2014-08-09 11:47

I've got two Giant owls stuck on this map:

http://dffd.wimbli.com/file.php?id=9332 [^]

Of note, this bug seems to also negatively effect animal breeding. In the two years since the owls got stuck, I've had only one domestic animal birth. I've had a peahen sitting on a clutch of 7 eggs for the entire age of the fort and boar/sow combo that's barren. Even more interesting, my cats haven't bred either.

This may be related to 0007651

Could also be related to the undead problems. There's an undead elf left over from a siege that's been idling on the map since the owls got stuck.

(0028692)
musicmastermsh (reporter)
2014-08-09 19:23

Stuck barn owl, dwarves breeding like alpacas, alpacas breeding like dwarves. (they're unmarried to they ain't doing squat) Haven't had any invasions or goblins so far, just some monkeys.

http://dffd.wimbli.com/file.php?id=9335 [^]
(0028702)
Borschwanger (reporter)
2014-08-10 00:22

I have had 9 Giant Wrens for a year and a quarter and they are too high to be hunted. Also have some carp that gave birth, not sure if they are supposed to stick around either. I have had both a kobold ambush and a goblin siege. The ewe/ram pair and my dogs have given birth. My cat pair has not. Haven't allowed eggs to sit for hatching since I couldn't hunt any food so that is as yet unknown. Lots of dwarf births.
(0028877)
Loci (manager)
2014-08-12 09:23

After a certain amount of time on the map, animal groups path to the map edge to migrate out. It appears that the "migrate out" code does not correctly handle critters without a walkable path to an edge (from flying, climbing, or swimming). Preventing fliers from becoming airborne (such as roofing over the floor of the caverns) allows them to migrate off the map successfully.

Since this bug completely breaks one of the more interesting aspects of the game, I think it should qualify for more than "minor" severity.
(0028925)
thvaz (reporter)
2014-08-13 00:12

I got ravens stuck in the air, but I have had invasions.
(0028971)
Robsoie (reporter)
2014-08-13 12:23
edited on: 2014-08-13 12:24

I experimented with a fortress of mine in 40.08, as despite i had only 20 dwarves the game was running much slower than it should .
I noticed i had 6 "kea" and 6 "sparrow men" stuck in the air all around the map, not moving.

I decided to edit the saved game own raw and remove the [FLIER] tag from both creature_birds.txt and creature_birds_new.txt files

Then i loaded that save, the 6 keas and the 6 sparrow men (or simple sparrow, i'm not sure i remember them right) fell to the ground, the sparrow men were more lucky as they landed in a tree top, allowing most of them to survive, while the keas were less lucky and all died.

Following that the game wasn't slow anymore, and was running quite fast actually (and much more in par with how it usually run with only 20 dwarves)

(0028990)
tacomagic (reporter)
2014-08-13 13:58

Through a series of tests we proved that there is actually no link between stuck birds and breeding:
http://www.bay12forums.com/smf/index.php?topic=142171.msg5570374#msg5570374 [^]

Thus, there is no relationship between this bug and 0007651.
(0028994)
Footkerchief (manager)
2014-08-13 15:38

I agree that there's probably no relationship, but proving one link doesn't disprove another link.
(0031916)
Footkerchief (manager)
2015-01-12 15:52

Reopened and awaiting a save.
(0031918)
ptb_ptb (reporter)
2015-01-12 21:23

Storkmen stuck over a volcano. Follow the stairs. :)

http://dffd.wimbli.com/file.php?id=10435 [^]
(0034039)
Killzemallgod (reporter)
2015-12-18 19:56

Seems to also effect flying guests.
0009382 http://www.bay12games.com/dwarves/mantisbt/view.php?id=9382 [^]

And 0009385 appears to be a copy of it.
http://www.bay12games.com/dwarves/mantisbt/view.php?id=9385 [^]

- Issue History
Date Modified Username Field Change
2014-07-08 16:34 psioryx New Issue
2014-07-08 16:49 Footkerchief Note Added: 0025178
2014-07-08 16:49 Footkerchief Assigned To => Footkerchief
2014-07-08 16:49 Footkerchief Status new => needs feedback
2014-07-08 18:30 psioryx Note Added: 0025200
2014-07-08 18:30 psioryx Status needs feedback => assigned
2014-07-11 07:32 Footkerchief Relationship added has duplicate 0007028
2014-07-11 20:21 Footkerchief Relationship added has duplicate 0007093
2014-07-11 20:21 Footkerchief Note Added: 0025919
2014-07-12 05:53 4maskwolf Note Added: 0025963
2014-07-12 14:21 eliotcougar Note Added: 0026023
2014-07-12 14:55 Rafal99 Note Added: 0026027
2014-07-12 19:37 Footkerchief Relationship added related to 0007170
2014-07-14 06:38 frodo0800 Note Added: 0026312
2014-07-19 08:21 exottoyuhr Note Added: 0026947
2014-07-19 08:42 exottoyuhr Note Edited: 0026947 View Revisions
2014-07-20 19:40 lethosor Issue Monitored: eliotcougar
2014-07-20 19:40 lethosor Issue Monitored: frodo0800
2014-07-20 19:40 lethosor Issue Monitored: Rafal99
2014-07-20 19:40 lethosor Note Added: 0027093
2014-07-20 20:24 lethosor Assigned To Footkerchief => lethosor
2014-07-21 04:35 lethosor Relationship added related to 0005421
2014-07-22 08:24 lethosor Status assigned => needs feedback
2014-07-26 05:14 Rafal99 Note Added: 0027585
2014-07-26 05:14 Rafal99 Note Edited: 0027585 View Revisions
2014-07-26 07:11 Footkerchief Relationship added has duplicate 0007644
2014-07-26 07:11 Footkerchief Issue Monitored: Kirkegaard
2014-07-26 08:09 Kirkegaard Note Added: 0027606
2014-07-26 08:10 Kirkegaard Note Edited: 0027606 View Revisions
2014-07-26 08:16 Dwarfu Note Added: 0027607
2014-07-26 08:34 Kirkegaard Note Added: 0027608
2014-07-26 15:22 Footkerchief Relationship added related to 0006545
2014-07-28 20:13 Talvieno Note Added: 0027845
2014-07-30 11:32 Footkerchief Relationship added has duplicate 0007742
2014-07-30 15:33 Ataman Note Added: 0027985
2014-07-30 18:43 lethosor Status needs feedback => acknowledged
2014-07-30 18:44 lethosor Note Added: 0027991
2014-07-30 18:44 lethosor Note Deleted: 0027991
2014-07-30 18:45 lethosor Relationship replaced child of 0007170
2014-07-31 01:05 Kirkegaard Note Added: 0028009
2014-07-31 01:54 Kirkegaard Note Deleted: 0028009
2014-07-31 05:13 4maskwolf Issue Monitored: 4maskwolf
2014-08-04 17:02 samanato Issue Monitored: samanato
2014-08-04 20:02 thescribblery Note Added: 0028336
2014-08-04 20:09 thescribblery Note Edited: 0028336 View Revisions
2014-08-04 20:10 thescribblery Note Edited: 0028336 View Revisions
2014-08-04 21:26 Dwarfu Summary Ravens stuck in mid air => Ravens stuck in mid air (prevents invasions?)
2014-08-04 23:29 thescribblery Note Deleted: 0028336
2014-08-05 03:36 Ataman Note Edited: 0027985 View Revisions
2014-08-09 11:30 tacomagic Note Added: 0028655
2014-08-09 11:30 tacomagic Note Edited: 0028655 View Revisions
2014-08-09 11:30 tacomagic Note Edited: 0028655 View Revisions
2014-08-09 11:36 tacomagic Note Edited: 0028655 View Revisions
2014-08-09 11:47 tacomagic Note Edited: 0028655 View Revisions
2014-08-09 12:20 Footkerchief Relationship added related to 0007651
2014-08-09 12:20 Footkerchief Status acknowledged => confirmed
2014-08-09 12:25 Footkerchief Relationship replaced related to 0007170
2014-08-09 12:27 Footkerchief Summary Ravens stuck in mid air (prevents invasions?) => Flying animals stuck in mid air (prevents invasions?)
2014-08-09 13:59 Dwarfu Relationship added has duplicate 0007926
2014-08-09 19:23 musicmastermsh Note Added: 0028692
2014-08-10 00:22 Borschwanger Note Added: 0028702
2014-08-12 08:48 Footkerchief Summary Flying animals stuck in mid air (prevents invasions?) => Flying animals (e.g. birds) stuck in mid air (prevents invasions?)
2014-08-12 08:48 Footkerchief Relationship added has duplicate 0007973
2014-08-12 09:23 Loci Note Added: 0028877
2014-08-13 00:12 thvaz Note Added: 0028925
2014-08-13 12:23 Robsoie Note Added: 0028971
2014-08-13 12:24 Robsoie Note Edited: 0028971 View Revisions
2014-08-13 13:58 tacomagic Note Added: 0028990
2014-08-13 15:38 Footkerchief Note Added: 0028994
2014-08-16 17:57 Button Issue Monitored: Button
2014-08-18 11:44 Footkerchief Relationship added has duplicate 0007840
2014-08-18 12:17 Toady One Status confirmed => resolved
2014-08-18 12:17 Toady One Fixed in Version => Next Version
2014-08-18 12:17 Toady One Resolution open => fixed
2014-08-18 12:17 Toady One Assigned To lethosor => Toady One
2014-08-18 12:27 Kirkegaard Issue End Monitor: Kirkegaard
2014-08-18 12:31 samanato Issue End Monitor: samanato
2014-08-20 02:27 Rafal99 Issue End Monitor: Rafal99
2014-08-20 07:27 4maskwolf Issue End Monitor: 4maskwolf
2014-08-26 09:36 Button Issue End Monitor: Button
2015-01-12 15:51 Footkerchief Status resolved => needs feedback
2015-01-12 15:51 Footkerchief Resolution fixed => reopened
2015-01-12 15:52 Footkerchief Note Added: 0031916
2015-01-12 21:23 ptb_ptb Note Added: 0031918
2015-03-29 08:48 Footkerchief Status needs feedback => confirmed
2015-12-18 19:56 Killzemallgod Note Added: 0034039
2016-08-07 07:10 Loci Relationship added related to 0009362
2017-06-08 19:16 Huntthetroll Issue Monitored: Huntthetroll


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker