Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007451Dwarf FortressDwarf Mode -- Reclaimpublic2014-07-18 08:202014-09-02 09:56
Reporterclanl 
Assigned ToToady One 
PrioritynormalSeveritycrashReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSWindows 7 64bitOS Version
Product Version0.40.03 
Target VersionFixed in Version0.40.10 
Summary0007451: Crash/freeze when reclaiming fort and unretiring adventurer
DescriptionI don't know which parts are important, so I'll try to summarize all I did in this world. The world was in the age of the glacier titan. A titan that resided at a shrine on a glacier
I did the following:

- Create dwarf adventurer
- kill titan
- claim shrine site for myself (just screaming it out)
retire adventurer in nearby fortress (I tried retiring right where I killed the titan but it didn't work)
- start fortress, embark right on the titan's shrine
- play for a while; as expected, world progresses into the Golden Age at the end of last year
- retire fortress
At this point I wanted to visit the fort with my old adventurer.
As it turns out, both unretiring the adventurer and reclaiming the fort makes DF crash/freeze immediately.

I think it's just a ordinary reclaim crash, but it might crash because I embarked on an existing site (the shrine).


Save is here:

http://dffd.wimbli.com/file.php?id=9053 [^]
Steps To ReproduceLoad save
Start game: adventure mode
try to unretire Edzul Ekurled from Sebirastis

or
Start game: fortress mode
try to reclaim Ushilkalur Nekukmond├╗l
Additional InformationThe shrine is called Sebirastis,
The adventurer is called Edzul Ekurled,
The fortress is called Ushilkalur Nekukmond├╗l

I also have a save where the fort isn't retired yet which I can upload if necessary.
TagsNo tags attached.
Attached Files

- Relationships
duplicate of 0006915resolvedToady One Crash when starting adventurer in retired fortress 
related to 0006523confirmedFootkerchief Crash after generating world and immediately reclaiming/unretiring a worldgen fortress 
related to 0008111resolvedToady One Trying to start as an adventurer at a player fortress crashes the game 
related to 0008122new Crash on loading adventurer saved in retired fort 

-  Notes
(0027042)
clanl (reporter)
2014-07-20 12:42
edited on: 2014-07-20 13:32

Unretiring either, adventurer or fort from this save still crashes in 40.04 for me.

(0029622)
Footkerchief (manager)
2014-08-25 14:10

Still crashing in 0.40.10?
(0029625)
clanl (reporter)
2014-08-25 15:08

I'm pretty busy right now, I'll test when I get to it (some time this week). My assumption is that the save where I already retired will still crash, but retiring again from an earlier save will work. Just never had the time to test it since then.
(0029892)
clanl (reporter)
2014-09-02 09:39

40.10, everything works. This can be closed.
(0029893)
Footkerchief (manager)
2014-09-02 09:56

Thanks for the update!

- Issue History
Date Modified Username Field Change
2014-07-18 08:20 clanl New Issue
2014-07-18 08:51 Footkerchief Relationship added duplicate of 0006915
2014-07-18 08:51 Footkerchief Status new => resolved
2014-07-18 08:51 Footkerchief Resolution open => duplicate
2014-07-18 08:51 Footkerchief Assigned To => Footkerchief
2014-07-20 12:42 clanl Note Added: 0027042
2014-07-20 12:42 clanl Status resolved => needs feedback
2014-07-20 12:42 clanl Resolution duplicate => reopened
2014-07-20 13:32 clanl Note Edited: 0027042 View Revisions
2014-07-29 10:43 Footkerchief Relationship added related to 0006523
2014-08-21 15:39 Footkerchief Relationship added related to 0008111
2014-08-22 15:51 Footkerchief Relationship added related to 0008122
2014-08-25 14:10 Footkerchief Note Added: 0029622
2014-08-25 15:08 clanl Note Added: 0029625
2014-08-25 15:08 clanl Status needs feedback => assigned
2014-09-02 09:39 clanl Note Added: 0029892
2014-09-02 09:56 Footkerchief Note Added: 0029893
2014-09-02 09:56 Footkerchief Status assigned => resolved
2014-09-02 09:56 Footkerchief Fixed in Version => 0.40.10
2014-09-02 09:56 Footkerchief Resolution reopened => fixed
2014-09-02 09:56 Footkerchief Assigned To Footkerchief => Toady One


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker