Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004331Dwarf FortressDwarf Mode -- Interface, Embarkpublic2011-03-25 06:252011-03-25 16:58
Assigned ToLogical2u 
StatusresolvedResolutionunable to reproduce 
PlatformOSOS Version
Product Version0.31.22 
Target VersionFixed in Version 
Summary0004331: Game crashes on embark every time
DescriptionAt embark "strike the earth" announcement, game crashes when you press esc to exit announcement.
Steps To ReproduceStart game in new world, go to embark screen. Select any location and assign skills and items to the embark group. Go to embark, and the "strike the earth" announcement appears as normal. Press esc key to exit announcement. Game crashes.
Additional InformationI have uploaded a copy of the world I am using in case there could be a problem with the specific land. [^]
TagsNo tags attached.
Attached Files

- Relationships
related to 0003846resolvedFootkerchief Game Crashes When ever I "prepare for journey carefully" 

-  Notes
Footkerchief (manager)
2011-03-25 06:54

Reminder sent to: Mazonas

Please upload to [^] instead.

Are you using any mods?
Mazonas (reporter)
2011-03-25 07:26

Hi, no mods being used. I did tweak the worldgen in-game, but only using the parameters provided in the basic game itself. I've reuploaded the file to df wimbli as requested. Would you prefer a full copy of the game or is just the save okay? [^]
Footkerchief (manager)
2011-03-25 07:59

Just the save should be fine.

Are you using any non-vanilla init options?

What size is your embark area?

What OS are you using? (that's always relevant for crashes, don't leave it blank)
Mazonas (reporter)
2011-03-25 08:04

Okay, running in compatability mode for XP service pack 3 works. FYI I'm using Win7
Mazonas (reporter)
2011-03-25 08:05


no intro
sound off
using a tileset I use on all games
show flow amounts is on
varied ground tiles is off

embark area 4x4

Thank you :)
Toady One (administrator)
2011-03-25 15:46

This doesn't reproduce for me, so it's going to be difficult to figure out. If anybody could try out the save and see if they get the same thing, maybe we can narrow it down as a Windows 7 specific crash?
Footkerchief (manager)
2011-03-25 16:08

It might be the 64-bit save compression issue. Mazonas, try turning off COMPRESSED_SAVES in init.txt and see if that helps.
Mazonas (reporter)
2011-03-25 16:34

... I am now incredibly confused.

It's stopped happening at all now, regardless of if I use compressed saves or not, compatability mode or not.

I do not know what caused it, but it seems to have got better all by itself. Huh.

Sorry, guys.
Logical2u (manager)
2011-03-25 16:58

Alright, I'll mark this as unable to reproduce then.

- Issue History
Date Modified Username Field Change
2011-03-25 06:25 Mazonas New Issue
2011-03-25 06:35 Mazonas Issue Monitored: Mazonas
2011-03-25 06:35 Mazonas Issue End Monitor: Mazonas
2011-03-25 06:54 Footkerchief Note Added: 0016567
2011-03-25 06:54 Footkerchief Tag Attached: AWAITING UPDATE
2011-03-25 07:26 Mazonas Note Added: 0016570
2011-03-25 07:46 Footkerchief Tag Detached: AWAITING UPDATE
2011-03-25 07:59 Footkerchief Note Added: 0016574
2011-03-25 08:04 Mazonas Note Added: 0016575
2011-03-25 08:05 Mazonas Note Added: 0016576
2011-03-25 08:10 Footkerchief Relationship added related to 0003846
2011-03-25 15:46 Toady One Note Added: 0016600
2011-03-25 15:46 Toady One Assigned To => Toady One
2011-03-25 15:46 Toady One Status new => acknowledged
2011-03-25 16:08 Footkerchief Note Added: 0016601
2011-03-25 16:34 Mazonas Note Added: 0016602
2011-03-25 16:58 Logical2u Note Added: 0016603
2011-03-25 16:58 Logical2u Status acknowledged => resolved
2011-03-25 16:58 Logical2u Resolution open => unable to reproduce
2011-03-25 16:58 Logical2u Assigned To Toady One => Logical2u

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker