Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005084Dwarf FortressDwarf Mode -- Jobs, Itemspublic2012-02-14 17:162017-11-22 15:32
Assigned Tolethosor 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusresolvedResolutionno change required 
PlatformOSOS Version
Product Version0.34.01 
Target VersionFixed in Version 
Summary0005084: Jeweler able to cut/encrust all stone as well as gems
DescriptionJeweler shop includes all available stone types, not just gems. When asked to cut sandstone, sandstone items appeared in the cut gem category (e.g. 'cushion sandstone cabochons'). Is this WAI?
Steps To ReproduceBuild a jeweler's workshop on a map with stone. Give it jobs.
Attached Files

- Relationships
has duplicate 0005115resolvedFootkerchief Jewelers workshop will cut any stone as a gem. 
has duplicate 0005109resolvedFootkerchief Jeweler's workshop allows cutting of non-gem items. 
has duplicate 0005526resolvedDwarfu Jeweler can cut native metal 
related to 0005275new Jeweler cuts fire clay, but no new name for fire clay gems 
related to 0005527resolvedFootkerchief Can make gem windows from cut stone 

-  Notes
Footkerchief (manager)
2012-02-14 18:20
edited on: 2012-02-14 20:22

Yeah, it's intended: [^]

barconis (reporter)
2012-02-14 20:07

Is there a specific mention of this change anywhere? Your note had bad links referring to crafting/decorating with bone, which had no apparent relation to the topic. My search fu isn't finding a discussion of the subject in the forums, other than mention that cuts were added. I suppose it's another way to use up surplus stone/train jewelers without using actual gems of value...
Footkerchief (manager)
2012-02-14 20:26
edited on: 2012-02-14 20:27

Ugh, that link imploded -- it's fixed now, but here's the relevant text:

"The cabochon rewrite extended to allowing each entity to pick from among the shapes defined in the raws for all of their gem cutting purposes, with different entries for non-precious stones vs. gems (to keep them cabochon'd on rock, we can handle exceptions later)."

If you check entity_default.txt, stone cabochons are explicitly allowed:


NW_Kohaku (reporter)
2012-02-16 18:04
edited on: 2012-02-16 18:04

There is a problem with the stones being cut like gems - glazes are considered "stones". This means that I glaze a clay statue with "oval ash glaze cabochons".

See: [^]

Pickled Tink (reporter)
2012-02-17 19:42

I have cut sandy clay, clay loam, and fire clay I imported. I then encrusted a bucket with them.

"This is a chestnut bucket. The handle is made from sandy clay. On the item is a image of a cage in fire clay by iteb Lularrith. On the item is a well-designed image of a traction bench in clay loam by iteb Lularrith."

cutting the imported clay left it as "fire clay" or "sandy clay", but it is treated as cut in the menus and lost its imported status.

I sincerely doubt this was intended behaviour.
JayJayForce (reporter)
2014-10-29 14:26

Confirmed for 0.40.14

Was able to cut Sandy Clay and Clay loam. Description did not change after they were cut, but they were placed into gem stockpile.
Detros (manager)
2014-12-24 15:30
edited on: 2014-12-24 15:57

Confirmed in 0.40.21. Save: [^]

I am cutting granite into all those four cabochons and storing them in gem stockpile. Their name and description changed when they have been cut, so it is not like at JayJayForce's place.

I have also managed to encrust some furniture in these cabochons. The description of the final item (<<*mica mechanisms*>>) is a bit weird, though:
"This is a superior quality mica mechanisms. On the item is a image of a cushion cabochon in granite by Onul Morulunal." That's a job for another bug report if there is none such yet.

Larix2 (reporter)
2014-12-24 20:28
edited on: 2014-12-24 20:36

Cutting of _stones_ is intended, i.e. it is no bug and shouldn't be "confirmed".

I can't see a problem with the item description either, apart from "a image".

I think the issue should be closed or renamed to reflect that the only actual bug remaining is 0005275 - clay can be cut, but gives a no-flavour "clay" gem that can be used for encrusting but has no entry in the gem stockpile. That one has been present since .34.x and exists in .40.22, as well.

Detros (manager)
2014-12-25 03:49
edited on: 2014-12-25 12:05

@Larix2: I was confirming cutting of stones still works so yes, this report can probably be closed. And if only that cut clay lacks the change of description, let's move to that 0005275.

Also, I have thought it should be "a(n) image of SOMETHING MADE FROM cushion cabochon in granite" rather than "a(n) image of cushion cabochon in granite". Or did encrust description change in this way? I have thought it was not like this in 0.34 I used to play?

Edit: Moved this grammar stuff to 0008664.

Talvieno (reporter)
2015-12-10 15:18

This can be closed, right?
lethosor (manager)
2016-05-17 17:06

PM me or another manager on the forums if this should be reopened.

- Issue History
Date Modified Username Field Change
2012-02-14 17:16 barconis New Issue
2012-02-14 18:20 Footkerchief Note Added: 0019583
2012-02-14 18:20 Footkerchief Status new => resolved
2012-02-14 18:20 Footkerchief Resolution open => no change required
2012-02-14 18:20 Footkerchief Assigned To => Footkerchief
2012-02-14 20:07 barconis Note Added: 0019589
2012-02-14 20:07 barconis Status resolved => needs feedback
2012-02-14 20:07 barconis Resolution no change required => reopened
2012-02-14 20:22 Footkerchief Note Edited: 0019583 View Revisions
2012-02-14 20:26 Footkerchief Note Added: 0019591
2012-02-14 20:27 Footkerchief Note Edited: 0019591 View Revisions
2012-02-14 20:27 Footkerchief Note Edited: 0019591 View Revisions
2012-02-15 07:15 Footkerchief Relationship added has duplicate 0005115
2012-02-15 07:15 Footkerchief Assigned To Footkerchief =>
2012-02-15 07:15 Footkerchief Status needs feedback => new
2012-02-15 07:15 Footkerchief Tag Attached: Intentional/Expected?
2012-02-15 07:15 Footkerchief Relationship added has duplicate 0005109
2012-02-15 07:16 Footkerchief Sticky Issue No => Yes
2012-02-15 07:17 Footkerchief Issue Monitored: Toady One
2012-02-16 18:04 NW_Kohaku Note Added: 0019885
2012-02-16 18:04 NW_Kohaku Note Edited: 0019885 View Revisions
2012-02-17 19:42 Pickled Tink Note Added: 0020006
2012-02-19 02:06 Footkerchief Relationship added related to 0005275
2012-03-02 17:31 Dwarfu Relationship added has duplicate 0005526
2012-03-02 17:31 Dwarfu Issue Monitored: zombiejustice
2012-03-02 17:32 Dwarfu Relationship added related to 0005527
2014-10-29 14:26 JayJayForce Note Added: 0030789
2014-10-29 17:03 Footkerchief Assigned To => Footkerchief
2014-10-29 17:03 Footkerchief Status new => confirmed
2014-12-24 15:30 Detros Note Added: 0031466
2014-12-24 15:33 Detros Issue Monitored: Detros
2014-12-24 15:57 Detros Note Edited: 0031466 View Revisions
2014-12-24 20:28 Larix2 Note Added: 0031467
2014-12-24 20:35 Larix2 Note Edited: 0031467 View Revisions
2014-12-24 20:36 Larix2 Note Edited: 0031467 View Revisions
2014-12-25 03:49 Detros Note Added: 0031468
2014-12-25 12:05 Detros Note Edited: 0031468 View Revisions
2015-12-10 15:18 Talvieno Note Added: 0033747
2016-05-17 17:06 lethosor Note Added: 0035212
2016-05-17 17:06 lethosor Status confirmed => resolved
2016-05-17 17:06 lethosor Resolution reopened => no change required
2016-05-17 17:06 lethosor Assigned To Footkerchief => lethosor
2017-11-22 15:32 Dwarfu Sticky Issue Yes => No

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker